LAN File Sender

Программа для пересылки файлов по локальной сети.
Особеность программы полягает в том, что программа отдает(отсылает, закачивает) файл/ы (и папки) , а не скачивает его/их из сервера.

Характеристика:
-передача файлов(макс.размер 2ГБ)
-передача папок(и подпапок)
-не нуждается в установке
-простой интерфейс
-минимум настроек
-возможность сохранить или загрузить список отправляемых файлов(и\или папок)
-функция "Your IP" позволяет быстро узнать свой IP-адрес
-список получателей(не нужно вводит каждый раз IP-адрес получателя)
-использует WinSock 1.1,должна работать в Windows 98 и WinE

Разделы:
Настройки
Контекст.меню
Отправка
Получение
Тех.вопросы
Помочь проэкту
О программе/справке


Настройки

"Save to by default" - путь к папке,куда будут приниматься файлы по умолчанию.
"Your Nick","Y.Nick" - ваш ник, который увидит получатель при приеме файлов.
"Autorun" - автозапуск после загрузки Windows, уберите галочку для отключения.
Список получателей(Receivers):
 -Для добавления получателя заполните поля "IP" и "Nick" и нажмите "Refresh". Если IP-адрес правельный , ник не содержит запрещеных символов и IP-адрес отсуствует в списке, получатель будет добавлен в список.
 -Для удаления получателя выбирете его из списка и нажмите клавишу "Delete".
 -Для редактирования получателя выбирите его из списка , измените необходимые данный в полях "IP" и "Nick",нажмите "Refresh".

Для подтверждения изменений нажмите "OK" , для отмены - "Cancel".


Меню

После запуска программа сворачивается в трей.
Клик левой кнопки мыши на значку вызывает окно отправки файлов Клик правой - контекстное меню.

"Send" - вызывает окно отправки файлов.
"Your IP" - выводит Ваш IP-адрес и автоматически копирует его в буфер обмена.
"Options- вызывает окно настроек.
"About" - о программе.
"Exit" - выход из программы.


Отправка файлов/папок

"Add files" - добаляет файлы в список для отправки(можно выбрать несколько файлов).
"Add folder" - добавляет папку в список.
"Load" - загрузка списка файлов\папок из текстового файла.
"Save" - сохранение списка в текстовый файл.
"Info..." - окно ввода инфы о файлах.См.далее.
"Clear" - очищает список.
После добавления файлов\папок в список выбирете получателя из списка "Select receiver" и нажмите "Send" для отправки.
Если получателя нет в списке , выбирите "Add..." , заполните поля и нажмите "OK".
После нажатия "Send" панель отправки будет заменина панелью состояния передачи.
Для отмены нажмите "Cancel".
После окончания передачи "Cancel" сменится на "Close" - окно можно закрыть.

Окно информации

Информация о файлах, которая будет видна получателю. Макс.длина - 255 символов.


Получения файлов

"Save to" - путь к папке куда будут приняты файлы.
"Size" - суммарный размер всех файлов.
"File count" - количество файлов.
"Folder count" - количество папок.
"From" - ник и IP-адрес отправителя. Нажмите для добавления его в список получателей(если его там нет)
Для получения файлов нажмите "Receive",для отмены - "Cancel".
После нажатия "Receive" панель получения будет заменина панелью состояния.
Для отмены нажмите "Cancel".

После окончания передачи "Cancel" сменится на "Close" - окно можно закрыть.


Технические вопросы

ОС : WINDOWS XP(в Win 98,Win ME ,WinE(эмулятор) тоже должно работать , но не проверял).
Опер.память : хз, 128MB должно хватить.
Сеть: LAN 10Mbit/s , можно больше , можно меньше - главное , что бы не глючило.
Для нормльной работы программы надо разрешить исходящие соединения TCP ,и входящие на порт TCP 3023.
Роутер должен поддерживать форвардинг на порт TCP 3023.


Помочь проэкту...

Если есть желание помочь проэкту, то всегда готовы принять материальную помощь(WebMoney,0.1 WMZ тоже помощь) или помощь хорошими идеями(желательно с исходником или описанием алгоритма).
Кошельки
WMZ154947288834
WMR201389280200
WMU116817044823
WME233429361735


Написано мной, сам юзаю.
Последний билд 1013 от 05.06.2006(когда справку компилил).
Жду Ваши идеи,вопросы и замечания.Мой ящик
Оф.страничка программы http://lanfs.narod.ru
Lord Phoenix :)